From 2025-08-25 09:50 CET to 2025-08-25 11:40 CET Second Screens were not working Our Engineering team has resolved the issue, but will continue on implementing further measures, to ensure this issue is not happening again. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Aug 25, 2025 - 12:11 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2025 - 11:36 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2025 - 10:18 CEST
Investigating
We are experiencing unexpected service downtime affecting a portion of our platform users. Immediate efforts are underway to diagnose and resolve the issue as quickly as possible. We will keep you updated as we progress.
Posted Aug 25, 2025 - 10:13 CEST
Identified
The issue has been identified and a fix is being implemented.