The scheduled maintenance has been completed. During that time a database migration took place which lasted around 40 minutes. During that time no payments with Finion Pay Services could be performed (Terminal payments, Credit Card payments, etc...)
Posted Feb 19, 2025 - 00:12 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2025 - 22:00 CET
Scheduled
We will be undergoing scheduled maintenance operation on our FinionPay database clusters, expected to last approximately 4 hours. Our aim is to ensure ongoing performance improvements and sustained service reliability.
You might experience minor service interruptions or decreased performance during this period. We appreciate your understanding and patience as we work to deliver an enhanced service experience.
Posted Feb 14, 2025 - 11:23 CET
This scheduled maintenance affected: Web Application and MySports API.